Current status: We've implemented the fix for this issue and monitored the environment to confirm that service was restored. If you experience additional issues or have questions, please open a support case via Snowflake Community or the Support page in Snowsight.
Customer experience: Customers hosted in the specified regions may have been unable to access or use Snowflake services and features using Snowsight.
Incident start time: 12:25 UTC April 16, 2026 Incident end time: 13:45 UTC April 16, 2026
Preliminary root cause: Some application instances entered a degraded state and were unable to handle downstream connections. Snowflake mitigated the issue by restarting the affected instances.
A root cause analysis (RCA) document will be published within five business days.
Posted Apr 16, 2026 - 15:08 UTC
Monitoring
Current status: We've implemented the fix for this issue, and we'll continue to monitor the environment until we're confident all services are functioning properly.
Customer experience: Customers hosted in the specified regions may have been unable to access or use Snowflake services and features using Snowsight.
Incident start time: 12:25 UTC April 16, 2026 Incident end time: 13:45 UTC April 16, 2026
Preliminary root cause: Some application instances entered a degraded state and were unable to handle downstream connections. Snowflake mitigated the issue by restarting the affected instances.
Posted Apr 16, 2026 - 14:08 UTC
This incident affected: GCP - US Central 1 (Iowa) (Applications).