14 Deployments Affected: INC0104466
Incident Report for Snowflake
Postmortem

Snowflake Engineering has completed the postmortem of this service incident. A detailed Root Cause Analysis (RCA) is available on the Snowflake Community site:
https://community.snowflake.com/s/article/INC0104466

Posted Mar 25, 2024 - 08:03 PDT

Resolved
Current status: We've implemented the fix for this issue and monitored the environment to confirm that service was restored. If you experience additional issues or have questions, please open a support case via Snowflake Community.
Customer experience: Customers hosted in the specified regions may have been unable to access or use Snowflake services and features using Snowsight via PrivateLink. Affected PrivateLink customers may have seen the error "Invalid CORS request" when attempting to perform actions in Snowsight, such as navigating the UI, creating/viewing worksheets, or switching roles.
Workaround: As the issue is specific to access via PrivateLink, affected customers may have been able to use public Snowflake URLs as an alternative.
Incident start time: 11:30 UTC March 14, 2024
Incident end time: 15:25 UTC March 14, 2024
Preliminary root cause: A recent Snowsight release contained a code issue that affected PrivateLink authentication under certain conditions.
A root cause analysis (RCA) document will be published within seven business days.
Posted Mar 14, 2024 - 09:09 PDT
Monitoring
Current status: We've implemented the fix for this issue, and we'll continue to monitor the environment until we're confident all services are functioning properly.
Customer experience: Customers hosted in the specified regions may have been unable to access or use Snowflake services and features using Snowsight via PrivateLink. Affected PrivateLink customers may have seen the error "Invalid CORS request" when attempting to perform actions in Snowsight, such as navigating the UI, creating/viewing worksheets, or switching roles.
Workaround: As the issue is specific to access via PrivateLink, affected customers may have been able to use public Snowflake URLs as an alternative.
Incident start time: 11:30 UTC March 14, 2024
Incident end time: 15:25 UTC March 14, 2024
Preliminary root cause: A recent Snowsight release contained a code issue that affected PrivateLink authentication under certain conditions.
Posted Mar 14, 2024 - 08:47 PDT
Update
Current status: We're continuing to investigate to determine the source of the issue. We'll provide another update within 60 minutes.
Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features using Snowsight via PrivateLink.
Workaround: Affected customers are advised to use the public Snowflake url, if they have the possiblity, until the issue is resolved.
Incident start time: 11:35 UTC March 14, 2024
Posted Mar 14, 2024 - 07:45 PDT
Investigating
Current status: We're investigating an issue with Snowsight. We'll provide an update within 60 minutes.
Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features using Snowsight via PrivateLink.
Incident start time: 11:35 UTC March 14, 2024
Posted Mar 14, 2024 - 06:38 PDT
This incident affected: AWS - Europe (London) (Snowsight), AWS - Asia Pacific (Mumbai) (Snowsight), AWS - Asia Pacific (Singapore) (Snowsight), AWS - Asia Pacific (Tokyo) (Snowsight), Azure - Canada Central (Toronto) (Snowsight), Azure - Central US (Iowa) (Snowsight), Azure - East US 2 (Virginia) (Snowsight), Azure - Australia East (New South Wales) (Snowsight), AWS - Asia Pacific (Seoul) (Snowsight), AWS - Europe (Stockholm) (Snowsight), AWS - Asia Pacific (Osaka) (Snowsight), GCP - US East 4 (N. Virginia) (Snowsight), AWS - Asia Pacific (Jakarta) (Snowsight), and AWS - US East (N. Virginia) (Snowsight).