Current status: Snowflake engineers have performed recovery actions to restore Snowsight availability and monitored the environment to confirm that service has resumed. We remain engaged with our third-party cloud platform provider as they work to identify root cause and follow-up actions. If you experience additional issues or have questions, please open a support case via Snowflake Community.
Customer experience: Customers hosted in the specified regions may have been unable to access or use Snowflake services and features using Snowsight.
Incident start time: 09:02 UTC January 08, 2026 Incident end time: 10:43 UTC January 08, 2026
Preliminary root cause: A third-party cloud platform experienced an as-yet-undiagnosed issue which caused underlying infrastructure for Snowsight to become unavailable.
A root cause analysis (RCA) document will be published within ten business days.
Posted Jan 08, 2026 - 12:18 UTC
Monitoring
Current status: Snowflake engineers have performed recovery actions to restore Snowsight connectivity and have confirmed that service has resumed.
Customer experience: Customers hosted in the specified regions may have been unable to access or use Snowflake services and features using Snowsight.
Incident start time: 09:02 UTC January 08, 2026 Incident end time: 10:43 UTC January 08, 2026
Preliminary root cause: A third-party cloud platform experienced an as-yet-undiagnosed issue which caused underlying infrastructure for Snowsight to become unavailable.
Posted Jan 08, 2026 - 11:15 UTC
Update
Current status: Snowflake engineers have performed recovery actions expected to restore Snowsight connectivity and are currently confirming that service has resumed. In parallel, we remain engaged with our cloud service provider (CSP) to identify and resolve the issue. This issue has been confirmed as being restricted to Snowsight availability. We'll provide another update within 30 minutes.
Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features using Snowsight.
ETA: Although an ETA is not yet available, our initial validations indicate service is beginning to return to expected levels.
Workaround: This issue impacts Snowsight availability only. Snowflake services and features remain available via all other methods of access.
Incident start time: 09:02 UTC January 08, 2026
Posted Jan 08, 2026 - 11:06 UTC
Identified
Current status: Snowflake engineers have performed recovery actions expected to restore Snowsight connectivity and are currently confirming that service has resumed. In parallel, we remain engaged with our cloud service provider (CSP) to identify and resolve the issue.This issue has been confirmed as being restricted to Snowsight availability, all other methods of We'll provide another update within 30 minutes.
Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features using Snowsight.
ETA: Although an ETA is not yet available, our initial validations indicate service is beginning to return to expected levels.
Workaround: This issue impacts Snowsight availability only. Snowflake services and features remain available via all other methods of access.
Incident start time: 09:02 UTC January 08, 2026
Posted Jan 08, 2026 - 10:59 UTC
Update
Current status: We've confirmed that this issue is restricted to Snowsight availability, all other methods of accessing Snowflake remain available. We're actively engaging with our cloud service provider (CSP) to identify and resolve the issue. We'll provide another update within 30 minutes.
Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features using Snowsight.
Workaround: This issue impacts Snowsight availability only. Snowflake services and features remain available via all other methods of access.
Incident start time: 09:02 UTC January 08, 2026
Posted Jan 08, 2026 - 10:30 UTC
Investigating
Current status: We're investigating an issue with Snowflake Data Cloud. We'll provide an update within 60 minutes.
Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features using Snowsight.
Posted Jan 08, 2026 - 09:38 UTC
This incident affected: Azure - West US 2 (Washington) (Applications).