2 Deployments Affected: INC0109198
Incident Report for Snowflake
Postmortem

Snowflake Engineering has completed the postmortem of this service incident. A detailed Root Cause Analysis (RCA) is available on the Snowflake Community site:
https://community.snowflake.com/s/article/INC0109198

Posted Jun 11, 2024 - 22:21 PDT

Resolved
Current status: We've implemented the fix for this issue and monitored the environment to confirm that service was restored. If you experience additional issues or have questions, please open a support case via Snowflake Community
Customer experience: Users with trial accounts may experience issues when using Streamlit in Snowflake and Notebook functionalities. Production accounts are not affected.
Incident start time: 05:27 UTC May 29, 2024
Incident end time: 07:20 UTC May 30, 2024
Preliminary root cause: Recent adjustments to the SiS/NB system, aimed at enhancing functionality, inadvertently impacted the usability of Trial Accounts.
A root cause analysis (RCA) document will be published within seven business days.
Posted May 30, 2024 - 00:47 PDT
Update
Current status: We've identified the source of the issue and successfully tested a fix in lower environments. We are currently implementing a fix to restore service. We'll provide another update within 5 hours.
Customer experience: Users with trial accounts may experience issues when using Streamlit in Snowflake and Notebook functionalities. Production accounts are not affected.
Incident start time: 05:27 UTC May 29, 2024
Posted May 29, 2024 - 20:01 PDT
Identified
Current status: We've identified the source of the issue, and we're developing and implementing a fix to restore service. We'll provide another update within 2 hours.
Customer experience: Users with trial accounts may experience issues when using Streamlit in Snowflake and Notebook functionalities. Production accounts are not affected.
Incident start time: 05:27 UTC May 29, 2024
Posted May 29, 2024 - 17:53 PDT
This incident affected: AWS - Canada (Central) (Snowsight) and AWS - US East (N. Virginia) (Snowsight).