Azure - West US 2 (Washington): INC0157956

Incident Report for Snowflake

Update

Current status: Although the broadest impact has been remediated by our third-party cloud platform, customers may still experience performance latency or degradation as our service provider continues to work on full restoration. As an ETA from them is unavailable, our service provider has advised these customers to enact failover to other regions where possible. We will continue to monitor the environment until we're confident all services are functioning properly.

Customer experience: Customers hosted in the specified regions may have been unable to start, resume, or manage virtual warehouses. Virtual warehouses may have appeared stuck in the associated state. At this time, there should be no further impact on virtual warehouses.

Incident start time: 05:15 UTC May 29, 2026
Incident end time: 07:24 UTC May 29, 2026

Preliminary root cause: A third-party cloud platform experienced a power outage in its data center, affecting the underlying infrastructure and causing increased latency and intermittent connectivity for some resources Snowflake depends on.
Posted May 29, 2026 - 12:40 UTC

Monitoring

Current status: We've coordinated with our third-party cloud platform to implement the fix for this issue, and we'll continue to monitor the environment until we're confident all services are functioning properly.

Customer experience: Customers hosted in the specified regions may be unable to start, resume, or manage virtual warehouses. Virtual warehouses may appear as stuck in the associated state. Existing warehouses that are already running may be unaffected.

Incident start time: 05:15 UTC May 29, 2026
Incident end time: 07:24 UTC May 29, 2026

Preliminary root cause: A third-party cloud platform experienced a power outage in its data center, affecting the underlying infrastructure and causing increased latency and intermittent connectivity for some resources Snowflake depends on.
Posted May 29, 2026 - 09:36 UTC

Update

Current status: We're seeing services recover as our third-party provider continues its efforts to restore its environment, and we're actively monitoring recovery as these actions progress. We'll provide another update within 60 minutes.

Customer experience: Customers hosted in the specified regions may be unable to start, resume, or manage virtual warehouses. Virtual warehouses may appear as stuck in the associated state. Existing warehouses that are already running may be unaffected.

ETA: An ETA is not yet available. We'll provide one as soon as possible.

Workaround: There are currently no available workarounds for this issue.

Incident start time: 05:15 UTC May 29, 2026
Posted May 29, 2026 - 08:45 UTC

Identified

Current status: We've identified an issue with a third-party cloud platform, and we're coordinating with the provider to develop and implement a fix to restore service. We'll provide another update within 60 minutes.

Customer experience: Customers hosted in the specified regions may be unable to start, resume, or manage virtual warehouses. Virtual warehouses may appear as stuck in the associated state. Existing warehouses that are already running may be unaffected.

ETA: An ETA is not yet available. We'll provide one as soon as possible.

Workaround: There are currently no available workarounds for this issue.

Incident start time: 05:15 UTC May 29, 2026
Posted May 29, 2026 - 07:45 UTC

Investigating

Current status: We're investigating an issue with Snowflake Data Cloud. We'll provide an update within 60 minutes.

Customer experience: Customers hosted in the specified regions may be unable to start, resume, or manage virtual warehouses. Virtual warehouses may appear as stuck in the associated state. Existing warehouses that are already running may be unaffected.

Incident start time: 05:15 UTC May 29, 2026
Posted May 29, 2026 - 06:47 UTC
This incident affects: Azure - West US 2 (Washington) (Virtual Warehouses).