AZURE - US East 2 (Virginia): SI-20201013
Incident Report for Snowflake
Postmortem

Dear Customer,

Snowflake Engineering has completed the postmortem of this service incident. A detailed Root Cause Analysis is made available on the Snowflake Community site.

https://community.snowflake.com/s/article/SI-20201013

We apologize for the service incident and the impact on your applications.

If you have any questions or difficulty accessing the Snowflake community site, please send feedback by submitting a support case via the Snowflake Community Site.

Thank you,

Snowflake Support

Posted Nov 03, 2020 - 17:29 PST

Resolved
The issue is now resolved.
A Root Cause Analysis (RCA) will be posted within the next ten business days.

We apologize for the inconvenience caused by this Incident.
If you have any questions or see any related issues, please open a support request ticket via the Snowflake Community Site.
Posted Oct 13, 2020 - 06:48 PDT
Monitoring
All fixes by AZURE are now complete. Snowflake engineering is now monitoring the system for any further recurrence of the problem and will remain in the Monitoring state for 30 minutes.

We apologize for the inconvenience.

If you have any questions or see any related issues, please submit a support request ticket via the Snowflake Community Site.
Posted Oct 13, 2020 - 06:09 PDT
Update
We are continuing to work with the Azure team on fixing the issue.

Azure is currently throttling the incoming queries to balance the workload on the deployment.
You may experience some of the following symptoms:
1. Queuing of queries
2. Queries not completing

Incident Start Time: 01:10 PT October 13, 2020

We will provide more information or give an update within the next 60 minutes.
Posted Oct 13, 2020 - 05:14 PDT
Update
We are continuing to work with the Azure team on fixing the issue.

Azure is currently throttling the incoming queries to balance the workload on the deployment.
You may experience some of the following symptoms:
1. Queuing of queries
2. Queries not completing

Incident Start Time: 01:10 PT October 13, 2020

We will provide more information or give an update within the next 30 minutes.
Posted Oct 13, 2020 - 04:38 PDT
Update
We are continuing to work with the Azure team on fixing the issue.

The issue is potentially related to Azure Blob storage access, which is causing Snowflake query performance degradation. You may experience some of the following symptoms:
1. Queuing of queries
2. Queries not completing

Incident Start Time: 01:10 PT October 13, 2020

We will provide more information or give an update within the next 30 minutes.
Posted Oct 13, 2020 - 04:05 PDT
Update
We are continuing to work on fixing the issue.

The issue is potentially related to Azure Blob storage access, which is causing Snowflake query performance degradation.

We are working with our partner Azure to identify the root cause.

You may experience some of the following symptoms:

1. Queuing of queries
2. Queries not completing

Incident Start Time: 01:10 PT October 13, 2020

We will provide more information on the potential issue update within the next 30 minutes.
Posted Oct 13, 2020 - 03:29 PDT
Identified
The issue is potentially related to Azure Blob storage access, which is causing Snowflake query performance degradation.

We are working with our partner Azure to identify the root cause.

You may experience some of the following symptoms:

1. Queuing of queries
2. Queries not completing

Incident Start Time: 01:10 PT October 13, 2020

We will provide more information on the potential issue update within the next 30 minutes.
Posted Oct 13, 2020 - 03:00 PDT
Investigating
We are investigating an issue with one of the Snowflake services.

You may experience some of the following symptoms;

1. Queuing of queries
2. Queries not completing

Incident Start Time: 01:10 PT October 13, 2020

We will provide more information on the potential issue update within the next 30 minutes.
Posted Oct 13, 2020 - 02:20 PDT
This incident affected: Azure - East US 2 (Virginia) (Snowflake Data Warehouse (Database)).