INC0131871

Incident Report for Snowflake

Resolved

Current status: We've implemented the fix for this issue and monitored the environment to confirm that service was restored. If you experience additional issues or have questions, please open a support case via Snowflake Community.

Customer experience: Customers hosted in the specified regions may have been unable to access or use Snowflake services and features using Snowsight. Customers may have observed new trial account creations failing and/or a blank white page/500 error being returned upon logging into Snowsight. As an alternative, customers were able to log in using other methods, such as SnowSQL, connectors, etc.

Incident start time: 03:20 UTC April 21, 2025
Incident end time: 04:09 UTC April 21, 2025

Preliminary root cause: A third-party service provider experienced an issue upon completing a scheduled maintenance window, which affected the caching service used for logins to the Snowflake UI. Snowflake engineers were engaged and reverted to a secondary data system to mitigate impacts.

A root cause analysis (RCA) document will be published within ten business days.
Posted Apr 20, 2025 - 22:34 PDT

Monitoring

Current status: We've implemented the fix for this issue, and we'll continue to monitor the environment until we're confident all services are functioning properly.

Customer experience: Customers hosted in the specified regions may have been unable to access or use Snowflake services and features using Snowsight. Customers may have observed new trial account creations failing and/or a blank white page/500 error being returned upon logging into Snowsight. As an alternative, customers were able to log in using other methods, such as SnowSQL, connectors, etc.

Incident start time: 03:20 UTC April 21, 2025
Incident end time: 04:09 UTC April 21, 2025

Preliminary root cause: A third-party service provider experienced an issue upon completing a scheduled maintenance window, which affected the caching service used for logins to the Snowflake UI. Snowflake engineers were engaged and reverted to a secondary data system to mitigate impacts.
Posted Apr 20, 2025 - 21:36 PDT

Identified

Current status: We've identified the source of the issue, and we're developing and implementing a fix to restore service. We'll provide another update within 60 minutes.

Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features using Snowsight. Customers may observe new trial account creations failing and/or a blank white page/500 error returned upon logging into Snowsight. As an alternative, customers can log in using other methods, such as SnowSQL, connectors, etc.

Incident start time: 03:20 UTC April 21, 2025
Posted Apr 20, 2025 - 20:59 PDT
This incident affected: Azure - Central US (Iowa) (Snowsight) and Azure - South Central US (Texas) (Snowsight).