AZURE - West Europe (Netherlands): SI-20201118
Incident Report for Snowflake
Postmortem

Dear Customer,

Snowflake Engineering has completed the postmortem of this service incident. A detailed Root Cause Analysis is made available on the Snowflake Community site.

https://community.snowflake.com/s/article/SI-20201118

We apologize for the service incident and the impact on your applications.

If you have any questions or difficulty accessing the Snowflake community site, please send feedback by submitting a support case via the Snowflake Community Site.

Thank you,

Snowflake Support

Posted Dec 08, 2020 - 18:14 PST

Resolved
The Service Incident is now closed.

A Root Cause Analysis (RCA) will be posted within the next ten business days.

We apologize for the inconvenience caused by this incident.

If you have any questions or experience any related issues, please open a support case via the Snowflake Community Site.
Posted Nov 18, 2020 - 13:39 PST
Monitoring
We applied a fix to resolve the issue.

Symptom(s): query failures, performance degradation
Incident Start Time: 02:00 PT November 18, 2020
Incident End Time: 10:30 PT November 18, 2020

We are now monitoring the system for any further recurrence of the problem. We will remain in this state for 60 minutes.

If you have any questions or experience any related issues, please open a support case via the Snowflake Community Site.
Posted Nov 18, 2020 - 12:42 PST
Update
We have identified the problem with the AZURE Platform resulting in the degraded performance of Snowflake Services. We're continuing to work closely with Azure Engineering to mitigate the problem.

Update:
The AZURE team is continuing to identify the faulty machine causing the degraded performance with query execution.

Snowflake engineering has not observed any new incidents in the past 3 hours.

Customer Action:
Please continue to run your workloads and monitor the progress closely before starting the next workload. The workloads may take longer than usual to complete.

Symptom(s): query failures, performance degradation
Incident Start Time: 02:00 PT November 18, 2020

We are working on mitigating the problem. We will update the status as soon as the issue is resolved or update within 60 minutes.
Posted Nov 18, 2020 - 11:07 PST
Update
We have identified the problem with the AZURE Platform resulting in the degraded performance of Snowflake Services. We're continuing to work closely with Azure Engineering to mitigate the problem.

Update:
AZURE team has narrowed down the problem to one cluster of machines causing the degraded performance with query execution. AZURE engineering is now taking steps to fix the issue.

Snowflake engineering did not observe any new incidents in the past 90 minutes.

Customer Action:
Please continue to run your workloads and monitor the progress closely before starting the next workload. The workloads may take longer than usual to complete.

Symptom(s): query failures, performance degradation
Incident Start Time: 02:00 PT November 18, 2020

We are working on mitigating the problem. We will update the status as soon as the issue is resolved or provide an update within 60 minutes.
Posted Nov 18, 2020 - 09:06 PST
Update
We have identified the problem with the AZURE Platform resulting in the degraded performance of Snowflake Services. We're continuing to work closely with Azure Engineering to mitigate the problem.

Update:
AZURE team has identified a potential problem with one machine causing the degraded performance with query execution. AZURE engineering is now taking steps to fix the issue.

Customer Action:
Please continue to run your workloads and monitor the progress closely before starting the next workload. The workloads may take longer than usual to complete.

Symptom(s): query failures, performance degradation
Incident Start Time: 02:00 PT November 18, 2020

We are working on mitigating the problem. We will update the status as soon as the issue is resolved or provide an update within 60 minutes.
Posted Nov 18, 2020 - 07:55 PST
Update
We have identified the problem with the AZURE Platform resulting in the degraded performance of Snowflake Services. We're continuing to work closely with Azure Engineering to mitigate the problem.

Update:
According to our findings, the query performance problem is intermittent. The queries may run successfully on subsequent automatic retries or when re-running the queries manually.

Customer Action:
Please continue to run your workloads and monitor the progress closely before starting the next workload. The workloads may take longer than usual to complete.

Symptom(s): query failures, performance degradation
Incident Start Time: 02:00 PT November 18, 2020

We are working on mitigating the problem. We will update the status as soon as the issue is resolved or provide an update within 60 minutes.
Posted Nov 18, 2020 - 06:52 PST
Update
We have identified the problem with the AZURE Platform resulting in the degraded performance of Snowflake Services. We're continuing to work closely with Azure Engineering to mitigate the problem.

According to our findings, the query performance problem is intermittent. The queries may run successfully on subsequent automatic retries or when re-running the queries manually.

Symptom(s): query failures, performance degradation
Incident Start Time: 02:00 PT November 18, 2020

We are working on mitigating the problem. We will update the status as soon as the issue is resolved or provide an update within 30 minutes.
Posted Nov 18, 2020 - 06:06 PST
Update
We have identified the problem with the AZURE Platform resulting in the degraded performance of Snowflake Services. We're continuing to work closely with Azure Engineering to mitigate the problem.

According to our findings, the query performance problem is intermittent. The queries may run successfully on subsequent automatic retries or when re-running the queries manually.

Symptom(s): query failures, performance degradation
Incident Start Time: 02:00 PT November 18, 2020

We are working on mitigating the problem. We will update the status as soon as the issue is resolved or provide an update within 30 minutes.
Posted Nov 18, 2020 - 05:35 PST
Update
We have identified the problem with the AZURE Platform resulting in the degraded performance of Snowflake Services. We're continuing to work closely with Azure Engineering to mitigate the problem.

According to our findings, the query performance problem is intermittent. The queries may run successfully on subsequent automatic retries or when re-running the queries manually.

Symptom(s): query failures, performance degradation
Incident Start Time: 02:00 PT November 18, 2020

We are working on mitigating the problem. We will update the status as soon as the issue is resolved or provide an update within 30 minutes.
Posted Nov 18, 2020 - 04:39 PST
Update
We have identified the problem with the AZURE Platform resulting in the degraded performance of Snowflake Services. We're working closely with Azure Engineering to mitigate the problem.

Symptom(s): query failures, performance degradation
Incident Start Time: 02:00 PT November 18, 2020

We are working on mitigating the problem. We will update the status as soon as the issue is resolved or provide an update within 30 minutes.
Posted Nov 18, 2020 - 04:03 PST
Update
We have identified the problem with the AZURE Platform that is resulting in degraded performance of Snowflake Services.

Symptom(s): query failures, performance degradation
Incident Start Time: 02:00 PT November 18, 2020

We are working on mitigating the problem. We will update the status as soon as the issue is resolved or provide an update within 30 minutes.
Posted Nov 18, 2020 - 03:33 PST
Identified
We have identified the problem with the Snowflake Service that is causing the following symptom:

Symptom(s): query failures, performance degradation
Incident Start Time: 02:00 PT November 18, 2020

We are working on mitigating the problem. We will update the status as soon as the issue is resolved or provide an update within 30 minutes.
Posted Nov 18, 2020 - 03:02 PST
Investigating
We are investigating an issue with Snowflake services.

Symptom(s): degraded query performance and query failures
Incident Start Time: 02:00 PT November 18, 2020

We will provide more information on the problem investigation status as soon as we have identified the problem or provide an update within 30 minutes.
Posted Nov 18, 2020 - 02:25 PST
This incident affected: Azure - West Europe (Netherlands) (Snowflake Data Warehouse (Database)).