Resolved
Current status: We've implemented the fix for this issue and monitored the environment to confirm that service was restored. If you experience additional issues or have questions, please open a support case via Snowflake Community or the Support page in Snowsight.
Customer experience: Customers hosted in the specified regions may have been unable to create or alter Snowflake alerts.
Incident start time: 14:53 UTC March 14, 2026
Incident end time: 04:39 UTC March 17, 2026
Preliminary root cause: A recent improvement to Snowflake alerts creation and alteration contained a code issue.
A root cause analysis (RCA) document will be published within five business days.
Posted Mar 17, 2026 - 05:49 UTC
Monitoring
Current status: We've finished rolling out the fix to restore service. We'll continue to monitor the environment until we're confident all services are functioning properly.
Customer experience: Customers hosted in the specified regions may have been unable to create or alter Snowflake alerts.
Incident start time: 14:53 UTC March 14, 2026
Incident end time: 04:39 UTC March 17, 2026
Preliminary root cause: A recent improvement to Snowflake alerts creation and alteration contained a code issue.
Posted Mar 17, 2026 - 04:58 UTC
Identified
Current status: We've determined a recent improvement to Snowflake alerts creation and alteration contains a code issue, which is causing the impact. We've developed a fix and are rolling it out to restore service. We'll provide another update within 6 hours.
Customer experience: Customers hosted in the specified regions may be unable to create or alter Snowflake alerts.
ETA: Our current estimate is that service will be restored for all affected customers within 6 hours. Customers will see relief as the fix rolls out. In the meantime, affected customers using replication in an unaffected region may initiate their failover procedures as a way to bypass the issue.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 14:53 UTC March 14, 2026
Posted Mar 16, 2026 - 23:45 UTC
Investigating
Current status: We're investigating an issue with Snowflake Data Cloud. We'll provide an update within 60 minutes.
Customer experience: Customers hosted in the specified regions may be unable to create or alter Snowflake alerts.
Incident start time: 14:53 UTC March 14, 2026
Posted Mar 16, 2026 - 22:46 UTC
This incident affected: AWS - US West (Oregon) (Alerts and Notifications), AWS - US West (Commercial Gov - Oregon) (Alerts and Notifications), AWS - US East (N. Virginia) (Alerts and Notifications), AWS - US East (Commercial Gov-Virginia) (Alerts and Notifications), AWS - South America (São Paulo) (Alerts and Notifications), AWS - Europe (Paris) (Alerts and Notifications), AWS - Europe (Zürich) (Alerts and Notifications), AWS - Europe (Stockholm) (Alerts and Notifications), AWS - Asia Pacific (Mumbai) (Alerts and Notifications), AWS - Asia Pacific (Singapore) (Alerts and Notifications), AWS - Asia Pacific (Jakarta) (Alerts and Notifications), AWS - Asia Pacific (Seoul) (Alerts and Notifications), AWS - Asia Pacific (Osaka) (Alerts and Notifications), Azure - South Central US (Texas) (Alerts and Notifications), Azure - Canada Central (Toronto) (Alerts and Notifications), Azure - East US 2 (Virginia) (Alerts and Notifications), Azure - Mexico (Central) (Alerts and Notifications), Azure - UK South (London) (Alerts and Notifications), Azure - Switzerland North (Zürich) (Alerts and Notifications), Azure - UAE North (Dubai) (Alerts and Notifications), Azure - Central India (Pune) (Alerts and Notifications), Azure - Central Korea (Seoul) (Alerts and Notifications), Azure - Japan East (Tokyo, Saitama) (Alerts and Notifications), Azure - Australia East (New South Wales) (Alerts and Notifications), GCP - Europe West 2 (London) (Alerts and Notifications), GCP - Europe West 4 (Eemshaven) (Alerts and Notifications), GCP - Europe West 3 (Frankfurt) (Alerts and Notifications), GCP - Middle East (Dammam) (Alerts and Notifications), Azure - Sweden Central (Gävle) (Alerts and Notifications), GCP - Australia Southeast 2 (Melbourne) (Alerts and Notifications), AWS - Middle East (UAE) (Alerts and Notifications), and Azure - East US (Virginia) (Alerts and Notifications).