2 Deployments Affected: INC0080066
Incident Report for Snowflake
Postmortem

Snowflake Engineering has completed the postmortem of this service incident. A detailed Root Cause Analysis (RCA) is available on the Snowflake Community site:

https://community.snowflake.com/s/article/INC0080066

Posted Mar 23, 2023 - 09:13 PDT

Resolved
Current status: We've implemented the fix for this issue and monitored the environment to confirm that service was restored.
Customer experience: Customer experience: Please clear all cookies relevant to Snowflake.com and attempt to retrieve resultsets from Snowsight UI.
Incident start time: 23:55 UTC March 08, 2023
Incident end time: 04:11 UTC March 09, 2023
Posted Mar 08, 2023 - 20:49 PST
Monitoring
Current status: We identified the root cause for the issue and have applied a fix. We will continue to monitor the environment to ensure it has fully recovered.
Customer experience: Please clear all cookies relevant to Snowflake.com and attempt to retrieve resultsets from Snowsight UI.
Incident start time: 23:55 UTC March 08, 2023
Incident end time: 04:11 UTC March 09, 2023
Posted Mar 08, 2023 - 20:23 PST
Identified
Current status: We identified a potential root cause for the issue and are working towards applying recovery mechanisms.
Customer experience: When trying to download resultset from Snowsight UI as a CSV or TSV, customers may see a JSON file get generated and get logged out. We'll provide an update within 60 minutes.
Workaround: A potential workaround is to complete the download resultset action while utilizing incognito mode in a browser.
Incident start time: 23:55 UTC March 08, 2023
Posted Mar 08, 2023 - 19:24 PST
Update
Current status: We are continuing to investigate other possible work streams to determine the cause.
Customer experience: When trying to download resultset from Snowsight UI as a CSV or TSV, customers may see a JSON file get generated and get logged out. We'll provide an update within 60 minutes.
Workaround: A potential workaround is to complete the download resultset action while utilizing incognito mode in a browser.
Incident start time: 23:55 UTC March 08, 2023
Posted Mar 08, 2023 - 18:25 PST
Update
Current status: We reverted a relevant configuration update which did not mitigate the issue. We are continuing to investigate other possible work streams to determine the cause. We'll provide an update within 60 minutes.

Customer experience: When trying to download resultset from Snowsight UI as a CSV or TSV, customers may see a JSON file get generated and get logged out.

Incident start time: 23:55 UTC March 08, 2023
Posted Mar 08, 2023 - 17:23 PST
Investigating
Current status: We're investigating an issue with Snowsight UI. When customers try to download data from Snowsight as a CSV or TSV, a JSON file gets generated and may log the customer out. We'll provide an update within 60 minutes.

Customer experience: When trying to download resultset from Snowsight UI as a CSV or TSV, customers may see a JSON file get generated and get logged out.

Incident start time: 23:55 UTC March 08, 2023
Posted Mar 08, 2023 - 16:24 PST
This incident affected: AWS - US East (N. Virginia) (Snowsight) and AWS - US West (Oregon) (Snowsight).