INC0159144

Incident Report for Snowflake

Monitoring

Current status: We've implemented the fix for this issue. Any customers still encountering the error condition may need to refresh their browser session. We'll continue to monitor the environment until we're confident all services are functioning properly.

Customer experience: Customers hosted in the specified regions may have been unable to use Git repository functionality in Workspaces, including pulling changes from a connected Git repository and performing related Git operations in a Git-synced workspace. Affected customers may have seen an error message: "Workspace feature disabled: Internal only system function."

Incident start time: 00:03 UTC June 16, 2026
Incident end time: 17:29 UTC June 16, 2026

Preliminary root cause: A recent Snowsight Workspaces software update changed how certain Workspace Git operations were routed and classified. Due to a code issue, some customer Git repository actions were tagged with an incorrect internal classification, causing those operations to fail.
Posted Jun 16, 2026 - 18:30 UTC

Update

Current status: We're continuing to roll back a recent software release affecting Git repository functionality in Snowsight Workspaces. The rollback of the affected release is approximately 70% completed. We will provide another update within four hours.

Customer experience: Customers hosted in the specified regions may be unable to use Git repository functionality in Workspaces, including pulling changes from a connected Git repository and performing related Git operations in a Git-synced workspace. Affected customers may see an error message: "Workspace feature disabled: Internal only system function."

ETA: Based on current progress, we expect the rollback to complete within the next four hours.

Workaround: While we're focused on remediation, please open a support case if you need immediate restoration of this functionality so we can apply a temporary account-level configuration change.

Incident start time: 00:03 UTC June 16, 2026
Posted Jun 16, 2026 - 14:36 UTC

Update

Current status: We've identified a recent release issue affecting Git repository functionality in Workspaces. The rollback of the affected release is continuing and is approximately halfway completed. We will provide another update within two hours.

Customer experience: Customers hosted in the specified regions may be unable to use Git repository functionality in Workspaces, including pulling changes from a connected Git repository and performing related Git operations in a Git-synced workspace. Affected customers may see an error message: "Workspace feature disabled: Internal only system function."

ETA: An ETA is not yet available. We'll provide one as soon as possible.

Workaround: While we're focused on remediation, please open a support case if you need immediate restoration of this functionality so we can apply a temporary account-level configuration change.

Incident start time: 00:03 UTC June 16, 2026
Posted Jun 16, 2026 - 12:29 UTC

Identified

Current status: We've identified a recent release issue affecting Git repository functionality in Workspaces. The rollback of the affected release is proceeding as expected across the environment. We will provide another update within 60 minutes.

Customer experience: Customers hosted in the specified regions may be unable to use Git repository functionality in Workspaces, including pulling changes from a connected Git repository and performing related Git operations in a Git-synced workspace. Affected customers may see an error message: "Workspace feature disabled: Internal only system function."

ETA: An ETA is not yet available. We'll provide one as soon as possible.

Workaround: While we're focused on remediation, please open a support case if you need immediate restoration of this functionality so we can apply a temporary account-level configuration change.

Incident start time: 00:03 UTC June 16, 2026
Posted Jun 16, 2026 - 11:29 UTC

Investigating

Current status: We've identified a recent release issue affecting Git repository functionality in Workspaces. We're rolling back the affected release across the environment and will provide another update within 60 minutes.

Customer experience: Customers hosted in the specified regions may be unable to use Git repository functionality in Workspaces, including pulling changes from a connected Git repository and performing related Git operations in a Git-synced workspace. Affected customers may see an error message: "Workspace feature disabled: Internal only system function."

Workaround: While we're focused on remediation, please open a support case if you need immediate restoration of this functionality so we can apply a temporary account-level configuration change.

Incident start time: 00:03 UTC June 16, 2026
Posted Jun 16, 2026 - 10:29 UTC
This incident affects: AWS - US West (Oregon) (Applications), AWS - Canada (Central) (Applications), AWS - US East (Ohio) (Applications), AWS - US East (N. Virginia) (Applications), AWS - Europe (Ireland) (Applications), AWS - Europe (London) (Applications), AWS - Europe (Frankfurt) (Applications), AWS - Asia Pacific (Mumbai) (Applications), AWS - Asia Pacific (Singapore) (Applications), AWS - Asia Pacific (Sydney) (Applications), AWS - Asia Pacific (Tokyo) (Applications), Azure - West US 2 (Washington) (Applications), Azure - Canada Central (Toronto) (Applications), Azure - Central US (Iowa) (Applications), Azure - East US 2 (Virginia) (Applications), Azure - US Gov (Virginia) (Applications), Azure - West Europe (Netherlands) (Applications), Azure - Switzerland North (Zürich) (Applications), Azure - Southeast Asia (Singapore) (Applications), Azure - Australia East (New South Wales) (Applications), GCP - US Central 1 (Iowa) (Applications), GCP - Europe West 2 (London) (Applications), GCP - Europe West 4 (Eemshaven) (Applications), AWS - Asia Pacific (Seoul) (Applications), Azure - North Europe (Ireland) (Applications), AWS - GovCloud (US-West) (Applications), Azure - Japan East (Tokyo, Saitama) (Applications), AWS - Europe (Stockholm) (Applications), AWS - US East (Commercial Gov-Virginia) (Applications), Azure - UAE North (Dubai) (Applications), Azure - South Central US (Texas) (Applications), Azure - Central India (Pune) (Applications), AWS - Asia Pacific (Osaka) (Applications), GCP - US East 4 (N. Virginia) (Applications), AWS - South America (São Paulo) (Applications), Azure - UK South (London) (Applications), AWS - Europe (Paris) (Applications), AWS - Asia Pacific (Jakarta) (Applications), AWS - Europe (Zürich) (Applications), AWS GovCloud - DoD (Applications), GCP - Europe West 3 (Frankfurt) (Applications), GCP - Middle East (Dammam) (Applications), Azure - Mexico (Central) (Applications), AWS - US West (Commercial Gov - Oregon) (Applications), Azure - Central Korea (Seoul) (Applications), AWS - Africa (Cape Town) (Applications), Azure - Sweden Central (Gävle) (Applications), GCP - Australia Southeast 2 (Melbourne) (Applications), Azure - East US (Virginia) (Applications), AWS - GovCloud (US-East) (Applications), AWS - Asia Pacific (Malaysia) (Applications), AWS - Asia Pacific (Thailand) (Applications), and AWS - Asia Pacific (New Zealand) (Applications).