Current status: Our third-party cloud platform implemented a mitigation and is in the process of recovery, which we are also seeing signs of. However, services continue to be impacted due to third-party service provider backlog and capacity issues, with the largest impact observed in virtual warehouse management. We'll provide another update within 60 minutes.
Customer experience: Customers hosted in the specified regions may experience intermittent delays or failures when accessing or using Snowflake services and features. This may include slower query execution, intermittent availability, or limited feature functionality.
ETA: An ETA is not yet available. We'll provide one as soon as possible. In the meantime, we recommend that affected customers using replication initiate their failover procedures.
Incident start time: 07:20 UTC October 20, 2025
Posted Oct 20, 2025 - 12:45 UTC
Update
Current status: Our third-party cloud platform implemented a mitigation and is in the process of recovery, which we are also seeing signs of. However, services continue to be impacted due to third-party service provider backlog, with the largest impact observed in virtual warehouse management. We'll provide another update within 60 minutes.
Customer experience: Customers hosted in the specified regions may experience intermittent delays or failures when accessing or using Snowflake services and features. This may include slower query execution, intermittent availability, or limited feature functionality.
ETA: An ETA is not yet available. We'll provide one as soon as possible. In the meantime, we recommend that affected customers using replication initiate their failover procedures.
Incident start time: 07:20 UTC October 20, 2025
Posted Oct 20, 2025 - 11:48 UTC
Update
Current status: Our third-party cloud platform implemented a mitigation and is in the process of recovery, which we are also seeing signs of. However, services continue to be impacted due to third-party service provider backlog, with the largest impact observed in virtual warehouse management. We'll provide another update within 60 minutes.
Customer experience: Customers hosted in the specified regions may experience intermittent delays or failures when accessing or using Snowflake services and features. This may include slower query execution, intermittent availability, or limited feature functionality.
ETA: An ETA is not yet available. We'll provide one as soon as possible. In the meantime, we recommend that affected customers using replication initiate their failover procedures.
Incident start time: 07:20 UTC October 20, 2025
Posted Oct 20, 2025 - 11:17 UTC
Update
Current status: Our third-party cloud platform implemented a mitigation, and we are slowly seeing signs of recovery. However, services continue to be impacted. We'll provide another update within 60 minutes.
Customer experience: Customers hosted in the specified regions may experience intermittent delays or failures when accessing or using Snowflake services and features. This may include slower query execution, intermittent availability, or limited feature functionality.
ETA: An ETA is not yet available. We'll provide one as soon as possible. In the meantime, we recommend that affected customers using replication initiate their failover procedures.
Incident start time: 07:20 UTC October 20, 2025
Posted Oct 20, 2025 - 10:25 UTC
Update
Current status: We're continuing to coordinate with our third-party cloud platform to develop and implement a fix to restore service. We'll provide another update within 60 minutes.
Customer experience: Customers hosted in the specified regions may experience intermittent delays or failures when accessing or using Snowflake services and features. This may include slower query execution, intermittent availability, or limited feature functionality.
ETA: An ETA is not yet available. We'll provide one as soon as possible. In the meantime, we recommend that affected customers using replication initiate their failover procedures.
Incident start time: 07:20 UTC October 20, 2025
Posted Oct 20, 2025 - 09:28 UTC
Identified
Current status: We've identified an issue with a third-party cloud platform, and we're coordinating with the provider to develop and implement a fix to restore service. We'll provide another update within 60 minutes.
Customer experience: Customers hosted in the specified regions may experience intermittent delays or failures when accessing or using Snowflake services and features. This may include slower query execution, intermittent availability, or limited feature functionality.
ETA: An ETA is not yet available. We'll provide one as soon as possible. In the meantime, we recommend that affected customers using replication initiate their failover procedures.
Incident start time: 07:20 UTC October 20, 2025
Posted Oct 20, 2025 - 08:36 UTC
This incident affects: AWS - US East (N. Virginia) (Virtual Warehouses, Data Loading and Unloading, Snowpark Container Services, AI and ML) and AWS - US East (Commercial Gov-Virginia) (Virtual Warehouses, Data Loading and Unloading, Snowpark Container Services, AI and ML).