AWS - US West (Oregon): INC0109106
Incident Report for Snowflake
Postmortem

Snowflake Engineering has completed the postmortem of this service incident. A detailed Root Cause Analysis (RCA) is available on the Snowflake Community site: https://community.snowflake.com/s/article/INC0109106

Posted Jun 09, 2024 - 22:59 PDT

Resolved
Current status: We've implemented the fix for this issue and monitored the environment to confirm that service was restored. If you experience additional issues or have questions, please open a support case via Snowflake Community.
Customer experience: A subset of customers might have encountered challenges during query execution, faced difficulties accessing their query history, and experienced performance issues while using Snowsight.
Incident start time: 16:50 UTC May 28, 2024
Incident end time: 03:17 UTC May 29, 2024
Preliminary root cause: We have identified an issue localized to a subset of our Metadata Database infrastructure. As part of the remediation activity, some Snowsight users might have encountered performance issues.
A root cause analysis (RCA) document will be published within seven business days.
Posted May 29, 2024 - 01:11 PDT
Update
Current status: We've implemented the fix for this issue, and we'll continue to monitor the environment until all services are fully recovered. While the fix takes effect on the affected instances, some customers may still encounter occasional issues.
Customer experience: A subset of customers might have encountered challenges during query execution, faced difficulties accessing their query history, and experienced performance issues while using Snowsight.
Incident start time: 16:50 UTC May 28, 2024
Incident end time: 03:17 UTC May 29, 2024
Preliminary root cause: We have identified an issue localized to a subset of our Metadata Database infrastructure. As part of the remediation activity, some Snowsight users would have encountered performance issues.
Posted May 28, 2024 - 23:50 PDT
Monitoring
Current status: We've implemented the fix for this issue, and we'll continue to monitor the environment until we're confident all services are functioning properly.
Customer experience: A subset of customers may have faced challenges during query execution and difficulties accessing their query history.
Incident start time: 16:50 UTC May 28, 2024
Incident end time: 03:17 UTC May 29, 2024
Preliminary root cause: We have identified an issue localized to a subset of our Metadata Database infrastructure.
Posted May 28, 2024 - 21:46 PDT
Update
Current status: We continue to investigate an issue within the Metadata Database layer and have isolated it to a subset of our Metadata Database infrastructure. Additionally, we've identified several data sets experiencing operational constraints, resulting in queries referencing them to fail. We're currently working on resolving these constraints to alleviate impacts. We will provide another update within 2 hours.
Customer experience: A specific subset of customers whose queries reference a particular table we've identified as affected may encounter challenges during query execution, as well as difficulties accessing their query history.
Incident start time: 16:50 UTC May 28, 2024
Posted May 28, 2024 - 19:50 PDT
Update
Current status: We continue to investigate an issue within the Metadata Database layer and have isolated it to a subset of our Metadata Database infrastructure. Additionally, we've identified several data sets experiencing operational constraints, resulting in queries referencing them to fail. We're currently working on resolving these constraints to alleviate impacts. We will provide another update within 2 hours.
Customer experience: A specific subset of customers whose queries reference a particular table we've identified as affected may encounter challenges during query execution, as well as difficulties accessing their query history.
Incident start time: 16:50 UTC May 28, 2024
Posted May 28, 2024 - 17:48 PDT
Update
Current status: We're continuing to investigate an issue within the Metadata Database layer and have isolated the issue to a subset of the Metadata Database infrastructure. We will provide another update within 120 minutes.
Customer experience: A subset of customers may experience issues with viewing their query history.
Incident start time: 16:50 UTC May 28, 2024
Posted May 28, 2024 - 15:45 PDT
Update
Current status: We're continuing to investigate an issue within the Metadata Database layer and have isolated the issue to a subset of the Metadata Database infrastructure. We will provide another update within 60 minutes.
Customer experience: A subset of customers may experience issues with viewing their query history.
Incident start time: 16:50 UTC May 28, 2024
Posted May 28, 2024 - 14:32 PDT
Update
Current status: We're continuing to investigate an issue within the Metadata Database layer and will provide another update within 60 minutes.
Customer experience: A subset of customers may experience issues with viewing their query history.
Incident start time: 16:50 UTC May 28, 2024
Posted May 28, 2024 - 13:32 PDT
Update
Current status: We're continuing to investigate the issue with Snowflake Data Cloud. We'll provide another update within 60 minutes.
Customer experience: A subset of customers may experience issues with viewing their query history.
Incident start time: 16:50 UTC May 28, 2024
Posted May 28, 2024 - 12:34 PDT
Investigating
Current status: We're investigating an issue with Snowflake Data Cloud. We'll provide an update within 60 minutes.
Customer experience: A subset of customers may experience issues with viewing their query history.
Incident start time: 16:50 UTC May 28, 2024
Posted May 28, 2024 - 11:41 PDT
This incident affected: AWS - US West (Oregon) (Snowflake Data Warehouse (Database)).