Resolved
Current status: We've confirmed that the rollback of the impacting Snowflake Intelligence update has completed, and we'll continue to monitor the environment until we're confident all services are functioning properly.
Customer experience: Customers hosted in the specified regions may have been unable to use Snowflake Intelligence services and features. Additionally, users may have experienced issues with expired sessions attempting to access Snowflake Intelligence. Existing sessions should have been unaffected.
Workaround: While we were focused on remediation, users may have been able to work around the issue by accessing the service directly via the non-account-specific URL, AI.Snowflake.com, in a private browser tab.
Incident start time: 16:30 UTC March 12, 2026
Incident end time: 20:39 UTC March 12, 2026
Preliminary root cause: An update intended to optimize Snowflake Intelligence introduced a code issue that caused problems with expired sessions attempting to access Snowflake Intelligence.
Posted Mar 12, 2026 - 23:13 UTC
Monitoring
Current status: We've confirmed that the rollback of the impacting Snowflake Intelligence update has completed, and we'll continue to monitor the environment until we're confident all services are functioning properly.
Customer experience: Customers hosted in the specified regions may have been unable to use Snowflake Intelligence services and features. Additionally, users may have experienced issues with expired sessions attempting to access Snowflake Intelligence. Existing sessions should have been unaffected.
Workaround: While we were focused on remediation, users may have been able to work around the issue by accessing the service directly via the non-account-specific URL, AI.Snowflake.com, in a private browser tab.
Incident start time: 16:30 UTC March 12, 2026
Incident end time: 20:39 UTC March 12, 2026
Preliminary root cause: An update intended to optimize Snowflake Intelligence introduced a code issue that caused problems with expired sessions attempting to access Snowflake Intelligence.
Posted Mar 12, 2026 - 21:50 UTC
Update
Current status: We're continuing to monitor as the rollback of the Snowflake Intelligence update progresses. Affected customers should continue to experience relief as the rollback advances and reaches their environment. We'll provide another update within 4 hours.
Customer experience: Customers hosted in the specified regions may be unable to use Snowflake Intelligence services and features. Additionally, users may experience issues with expired sessions attempting to access Snowflake Intelligence. Existing sessions should be unaffected.
ETA: Our current estimate is that service will be restored within approximately 4 hours. We're continuing to monitor the rollback's progress to ensure this timeline remains accurate.
Workaround: While we're focused on remediation, users may be able to work around the issue by accessing the service directly via the non-account-specific URL, AI.Snowflake.com, in a private browser tab.
Posted Mar 12, 2026 - 20:18 UTC
Identified
Current status: We're aware of an issue affecting the Snowflake Data Cloud, and we've identified the source as a recent Snowflake Intelligence update. We're rolling back the change to restore service. Customers should experience relief as the rollback progresses across the affected infrastructure. We'll provide another update within 2 hours.
Customer experience: Customers hosted in the specified regions may be unable to use Snowflake Intelligence services and features. Additionally, users may experience issues with expired sessions attempting to access Snowflake Intelligence. Existing sessions should be unaffected.
ETA: An ETA is not yet available. We'll provide one as soon as possible.
Workaround: While we're focused on remediation, please access the service or content using the AI.Snowflake.com URL through a private browser tab.
Posted Mar 12, 2026 - 19:42 UTC
This incident affected: AWS - US West (Oregon) (AI and ML), AWS - Canada (Central) (AI and ML), AWS - Europe (Ireland) (AI and ML), AWS - Europe (London) (AI and ML), AWS - Europe (Zürich) (AI and ML), AWS - Europe (Frankfurt) (AI and ML), AWS - Europe (Stockholm) (AI and ML), AWS - Africa (Cape Town) (AI and ML), AWS - Asia Pacific (Mumbai) (AI and ML), AWS - Asia Pacific (Singapore) (AI and ML), AWS - Asia Pacific (Jakarta) (AI and ML), AWS - Asia Pacific (Seoul) (AI and ML), AWS - Asia Pacific (Sydney) (AI and ML), AWS - Asia Pacific (Osaka) (AI and ML), AWS - Asia Pacific (Tokyo) (AI and ML), Azure - West US 2 (Washington) (AI and ML), Azure - South Central US (Texas) (AI and ML), Azure - Central US (Iowa) (AI and ML), Azure - Canada Central (Toronto) (AI and ML), Azure - East US 2 (Virginia) (AI and ML), Azure - Mexico (Central) (AI and ML), Azure - North Europe (Ireland) (AI and ML), Azure - UK South (London) (AI and ML), Azure - West Europe (Netherlands) (AI and ML), Azure - Switzerland North (Zürich) (AI and ML), Azure - UAE North (Dubai) (AI and ML), Azure - Southeast Asia (Singapore) (AI and ML), Azure - Central Korea (Seoul) (AI and ML), Azure - Japan East (Tokyo, Saitama) (AI and ML), Azure - Australia East (New South Wales) (AI and ML), GCP - US Central 1 (Iowa) (AI and ML), GCP - US East 4 (N. Virginia) (AI and ML), GCP - Europe West 2 (London) (AI and ML), GCP - Europe West 4 (Eemshaven) (AI and ML), GCP - Europe West 3 (Frankfurt) (AI and ML), GCP - Middle East (Dammam) (AI and ML), AWS - US East (Ohio) (AI and ML), AWS - US East (N. Virginia) (AI and ML), AWS - South America (São Paulo) (AI and ML), AWS - Europe (Paris) (AI and ML), Azure - Central India (Pune) (AI and ML), Azure - Sweden Central (Gävle) (AI and ML), GCP - Australia Southeast 2 (Melbourne) (AI and ML), AWS - Middle East (UAE) (AI and ML), and Azure - East US (Virginia) (AI and ML).