INC0135370

Incident Report for Snowflake

Resolved

Current status: We've completed our effort to reprocess the backlog of account organization metadata and monitored the environment to validate that service is restored. If you experience additional issues or have questions, please open a support case via Snowflake Community.

Customer experience: A subset of customers hosted in the specified regions were unable to access Snowflake services and features, or were experiencing replication failures related to missing account organization metadata. This could have resulted in HTTP 404 errors or failures when attempting to use Snowflake services and features that rely on organization name metadata or the [orgname]-[account_name] URL format. Additionally, affected customers may have experienced failures when attempting to manage failover groups.

Workaround: For some impact scenarios, such as access via Snowsight or connectors, customers may have been able to work around this issue by switching from an account name format (e.g., [orgname]-[account_name]) to a region-based account locator format, such as [account_locator].[cloud_region_id]. Users could have reviewed the following documentation https://docs.snowflake.com/en/user-guide/admin-account-identifier#using-an-account-locator-as-an-identifier for more information on account identifier formats.

Incident start time: 19:42 UTC June 09, 2025
Incident end time: 19:18 UTC June 11, 2025

Preliminary root cause: We determined this issue was the result of a recent configuration change that impacted a system service responsible for replicating account metadata across U.S. regions supporting public sector workloads.

A root cause analysis (RCA) document will be published within seven business days.
Posted Jun 11, 2025 - 13:50 PDT

Update

Current status: We are continuing to reprocess the backlog of account organization metadata to fully resolve the issue. As this work progresses across different regions, customers may experience service recovery at different times. Based on the current progress, we are updating our estimated time for full recovery to 20:00 UTC on June 11, 2025.

Customer experience: A subset of customers hosted in the specified regions are unable to access Snowflake services and features, or are experiencing replication failures related to missing account organization metadata. This can result in HTTP 404 errors or failures when attempting to use Snowflake services and features that rely on organization name metadata or the [orgname]-[account_name] URL format. Additionally, affected customers may experience failures when attempting to manage failover groups.

Workaround: For some impact scenarios, such as access via Snowsight or connectors, customers may be able to work around this issue by switching from an account name format (e.g. [orgname]-[account_name]) to a region-based account locator format, such as [account_locator].[cloud_region_id]. Please see https://docs.snowflake.com/en/user-guide/admin-account-identifier#using-an-account-locator-as-an-identifier for more information on account identifier formats.

ETA: 20:00 UTC June 11, 2025

Incident start time: 19:42 UTC June 09, 2025
Posted Jun 11, 2025 - 01:18 PDT

Update

Current status: We are continuing to reprocess the backlog of account organization metadata to fully resolve the issue. As this completes across different regions, customers will experience service recovery at different times. We are continuing to investigate options to more quickly process the backlog, but based on the current progress, we expect this to complete by 08:00 UTC on June 11, 2025.

Customer experience: A subset of customers hosted in the specified regions are unable to access Snowflake services and features, or are experiencing replication failures related to missing account organization metadata. This can result in HTTP 404 errors or failures when attempting to use Snowflake services and features that rely on organization name metadata or the [orgname]-[account_name] URL format. Additionally, affected customers may experience failures when attempting to manage failover groups.

Workaround: For some impact scenarios, such as access via Snowsight or connectors, customers may be able to work around this issue by switching from an account name format (e.g. [orgname]-[account_name]) to a region-based account locator format, such as [account_locator].[cloud_region_id]. Please see https://docs.snowflake.com/en/user-guide/admin-account-identifier#using-an-account-locator-as-an-identifier for more information on account identifier formats.

ETA: 08:00 UTC June 11, 2025

Incident start time: 00:10 UTC June 10, 2025
Posted Jun 10, 2025 - 15:02 PDT

Update

Current status: We have taken action to revert the configuration update causing the issue; however, a backlog of account organization metadata must be reprocessed to fully resolve the impact, which may take several hours to complete. In parallel, we are investigating options to more quickly process the backlog, and we'll provide another update within 2 hours.

Customer experience: A subset of customers hosted in the specified regions are unable to access Snowflake services and features, or are experiencing replication failures related to missing account organization metadata. This can result in HTTP 404 errors or failures when attempting to use Snowflake services and features that rely on organization name metadata or the [orgname]-[account_name] URL format. Additionally, affected customers may experience failures when attempting to manage failover groups.

Workaround: For some impact scenarios, such as access via Snowsight or connectors, customers may be able to work around this issue by switching from an account name format (e.g. [orgname]-[account_name]) to a region-based account locator format, such as [account_locator].[cloud_region_id]. Please see https://docs.snowflake.com/en/user-guide/admin-account-identifier#using-an-account-locator-as-an-identifier for more information on account identifier formats.

ETA: An ETA is not yet available.

Incident start time: 00:10 UTC June 10, 2025
Posted Jun 10, 2025 - 13:05 PDT

Identified

Current status: We've identified a recent configuration update that impacted a system service that facilitates replication of account metadata across U.S. regions supporting public sector workloads. We're developing and implementing a fix to restore service. We'll provide another update within 2 hours.

Customer experience: A subset of customers hosted in the specified regions are unable to access Snowflake services and features, or are experiencing replication failures related to missing account organization metadata. This can result in HTTP 404 errors or failures when attempting to use Snowflake services and features that rely on organization name metadata or the [orgname]-[account_name] URL format. Additionally, affected customers may experience failures when attempting to manage failover groups.

Workaround: For some impact scenarios, such as access via Snowsight or connectors, you may be able to workaround this issue by switching the account format you are using from an account name format (e.g. [orgname]-[account_name]) to a regioned account locator format, such as [account_locator].[cloud_region_id]. Please see https://docs.snowflake.com/en/user-guide/admin-account-identifier#using-an-account-locator-as-an-identifier for more information on account identifier formats.

ETA: An ETA is not yet available.

Incident start time: 00:10 UTC June 10, 2025
Posted Jun 10, 2025 - 11:06 PDT
This incident affected: Azure - US Gov (Virginia) (Snowflake Data Warehouse (Database), Replication), AWS - GovCloud (US-West) (Snowflake Data Warehouse (Database), Replication), AWS - GovCloud (US-East) (Snowflake Data Warehouse (Database), Replication), and AWS GovCloud - DoD (Snowflake Data Warehouse (Database), Replication).