AWS - US West (Oregon): INC0131721

Incident Report for Snowflake

Postmortem

Snowflake Engineering has completed the postmortem of this service incident. A detailed Root Cause Analysis (RCA) is available on the Snowflake Community site: https://community.snowflake.com/s/article/INC0131721

Posted Apr 24, 2025 - 08:54 PDT

Resolved

Current status: We've implemented the fix for this issue and monitored the environment to confirm that service was restored. If you experience additional issues or have questions, please open a support case via Snowflake Community.

Customer experience: Customers hosted in the specified regions may have experienced delays while attempting to execute queries. Affected customers may have seen warehouses stuck in a "resuming" status. Additionally, replication to and from the specified region may have appeared stuck or delayed.

Incident start time: 18:53 UTC April 16, 2025
Incident end time: 19:42 UTC April 16, 2025

Preliminary root cause: An infrastructure component that facilitates part of the warehouse provisioning process entered a degraded state.

A root cause analysis (RCA) document will be published within seven business days.
Posted Apr 16, 2025 - 14:10 PDT

Monitoring

Current status: We've implemented the fix for this issue, and we'll continue to monitor the environment until we're confident all services are functioning properly.

Customer experience: Customers hosted in the specified regions may have experienced delays while attempting to execute queries. Affected customers may have seen warehouses stuck in a "resuming" status. Additionally, replication to and from the specified region may have appeared stuck or delayed.

Incident start time: 18:53 UTC April 16, 2025
Incident end time: 19:42 UTC April 16, 2025

Preliminary root cause: An infrastructure component that facilitates part of the warehouse provisioning process entered a degraded state.
Posted Apr 16, 2025 - 13:14 PDT

Identified

Current status: We've identified the source of the issue, and we're developing and implementing a fix to restore service. We'll provide another update within 60 minutes.

Customer experience: Customers hosted in the specified regions may experience delays while attempting to execute queries. Affected customers may see warehouses stuck in a "resuming" status.

Incident start time: 18:53 UTC April 16, 2025
Posted Apr 16, 2025 - 12:46 PDT

Investigating

Current status: We're investigating an issue with Snowflake Data Cloud. We'll provide an update within 60 minutes.

Customer experience: Customers hosted in the specified regions may experience delays while attempting to execute queries. Affected customers may see warehouses stuck in a "resuming" status.

Incident start time: 18:53 UTC April 16, 2025
Posted Apr 16, 2025 - 12:30 PDT
This incident affected: AWS - US West (Oregon) (Snowflake Data Warehouse (Database), Replication).