Current status: We've monitored the environment and confirmed the rollback restored service. If you experience additional issues or have questions, please open a support case via Snowflake Community or the Support page in Snowsight.
Customer experience: Customers hosted in the specified regions may have experienced Cortex Code in Snowsight stopping mid-response after completing only one step of a request. The response may have stopped without an error message or may have repeated without progressing.
Incident start time: 22:50 UTC May 14, 2026 Incident end time: 04:05 UTC May 15, 2026
Preliminary root cause: A recent update to Cortex Code introduced a code issue that caused Cortex Code in Snowsight to incorrectly halt responses, preventing requests from completing.
A root cause analysis (RCA) document will be published within five business days.
Posted May 15, 2026 - 05:25 UTC
Monitoring
Current status: We've identified and rolled back a Cortex Code update to resolve this issue. We'll continue to monitor the environment until we're confident all services are functioning properly.
Customer experience: Customers hosted in the specified regions may have experienced Cortex Code in Snowsight stopping mid-response after completing only one step of a request. The response may have stopped without an error message or may have repeated without progressing.
Incident start time: 22:50 UTC May 14, 2026 Incident end time: 04:05 UTC May 15, 2026
Preliminary root cause: A recent update to Cortex Code introduced a code issue that caused Cortex Code in Snowsight to incorrectly halt responses, preventing requests from completing.
Posted May 15, 2026 - 04:34 UTC
Investigating
Current status: We're investigating an issue with Snowflake Data Cloud. We'll provide an update within 60 minutes.
Customer experience: Customers hosted in the specified regions may experience Cortex Code in Snowsight stopping mid-response after completing only one step of a request. The response may stop without an error message or may repeat without progressing.
Posted May 15, 2026 - 04:01 UTC
This incident affected: AWS - US West (Oregon) (AI and ML), AWS - Asia Pacific (Sydney) (AI and ML), AWS - Asia Pacific (Tokyo) (AI and ML), and Azure - Australia East (New South Wales) (AI and ML).