Current status: The third-party cloud platform confirmed that the mitigation was complete, and its automated recovery system appears to have initiated. We independently monitored the environment and verified that service was restored. If you experience additional issues or have questions, please open a support case via Snowflake Community or the Support page in Snowsight.
Customer experience: Customers hosted in the specified regions may have been unable to connect to Snowflake via private connectivity solutions, such as PrivateLink. Other connection methods were unaffected.
Incident start time: 13:25 UTC August 20, 2026 Incident end time: 14:10 UTC August 20, 2026
Preliminary root cause: A third-party cloud platform experienced a virtual networking infrastructure issue, preventing customers from connecting to Snowflake via private connectivity solutions, such as PrivateLink. While we suspect that this issue may be a recurrence of a third-party cloud platform virtual networking problem, we remain closely engaged with our third-party cloud platform as they perform their own investigation into the underlying root cause of the issue.
A root cause analysis (RCA) will be conducted and a summary will be shared on the Snowflake status page within 10 business days.
Posted Aug 20, 2026 - 15:43 UTC
Monitoring
Current status: We've coordinated with our third-party cloud platform, which has implemented a mitigation for this issue. We will continue to monitor the environment until we're confident that all services are functioning properly.
Customer experience: Customers hosted in the specified regions may have been unable to connect to Snowflake via private connectivity solutions, such as PrivateLink. Other connection methods were unaffected.
Incident start time: 13:25 UTC August 20, 2026 Incident end time: 14:10 UTC August 20, 2026
Preliminary root cause: A third-party cloud platform experienced a virtual networking infrastructure issue, preventing customers from connecting to Snowflake via private connectivity solutions, such as PrivateLink.
Posted Aug 20, 2026 - 14:39 UTC
Identified
Current status: We're investigating an issue with Snowflake Data Cloud. We've engaged the associated Cloud Service Provider to investigate and troubleshoot this issue further. We'll provide an update within 30 minutes.
Customer experience: Customers hosted in the specified regions may have been unable to connect to Snowflake via private connectivity solutions, such as PrivateLink.
ETA: An ETA is not yet available. We'll provide one as soon as possible.
Incident start time: 13:25 UTC August 20, 2026
Posted Aug 20, 2026 - 14:19 UTC
Investigating
Current status: We're investigating an issue with Snowflake Data Cloud. We've engaged the associated Cloud Service Provider to investigate and troubleshoot this issue further. We'll provide an update within 60 minutes.
Customer experience: Customers hosted in the specified regions may have been unable to connect to Snowflake via private connectivity solutions, such as PrivateLink.
ETA: An ETA is not yet available. We'll provide one as soon as possible. In the meantime, we recommend that affected customers using replication initiate their failover procedures.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 13:25 UTC August 20, 2026
Posted Aug 20, 2026 - 13:47 UTC
This incident affected: Azure - East US 2 (Virginia) (Security and Privacy Features).