Current status: We've coordinated with our third-party service provider to implement the fix for this issue, and we've monitored the environment to confirm that service was restored. If you experience additional issues or have questions, please open a support case via Snowflake Community.
Customer experience: Customers hosted in the specified regions may have been unable to access or use Snowflake services and features.
Incident start time: 17:55 UTC June 12, 2025 Incident end time: 20:50 UTC June 12, 2025
Preliminary root cause: A third-party service provider experienced a service issue across multiple infrastructure regions, which caused impact to Snowflake customer environments hosted within the impacted provider regions.
A root cause analysis (RCA) document will be published within ten business days.
Posted Jun 12, 2025 - 17:48 PDT
Update
Current status: Our monitoring systems indicate all affected Snowflake service regions continue to show signs of significant recovery as of 23:50 UTC. We're continuing to monitor the environment until our third-party service provider has confirmed full recovery, and we're confident all services are functioning properly.
Customer experience: Customers hosted in the specified regions may have been unable to access or use Snowflake services and features.
Incident start time: 17:55 UTC June 12, 2025 Incident end time: 20:50 UTC June 12, 2025
Preliminary root cause: A third-party service provider experienced a service issue across multiple infrastructure regions, which caused impact to Snowflake customer environments hosted within the impacted provider regions.
Posted Jun 12, 2025 - 16:53 PDT
Monitoring
Current status: Our monitoring systems indicate all affected Snowflake service regions have experienced significant recovery as of 20:50 UTC. We're continuing to monitor the environment until our third-party service provider has confirmed full recovery and we're confident all services are functioning properly.
Customer experience: Customers hosted in the specified regions may have been unable to access or use Snowflake services and features.
Incident start time: 17:55 UTC June 12, 2025 Incident end time: 20:50 UTC June 12, 2025
Preliminary root cause: A third-party service provider experienced a service issue across multiple infrastructure regions, which caused impact to Snowflake customer environments hosted within the impacted provider regions.
Posted Jun 12, 2025 - 14:54 PDT
Update
Current status: We have started to observe some signals of recovery in the remaining affected region, GCP - US Central 1 (Iowa); however, we're still coordinating with our third-party service provider on a timeline for complete service restoration. We'll provide another update within 60 minutes.
Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features.
ETA: An ETA is not yet available. We'll provide one as soon as possible. In the meantime, we recommend that affected customers using replication across alternate cloud providers or currently unaffected regions initiate their failover procedures.
Incident start time: 17:55 UTC June 12, 2025
Posted Jun 12, 2025 - 13:53 PDT
Update
Current status: We're continuing to coordinate with our third-party service provider, who has confirmed a service issue affecting multiple regions. At this time, our third-party service provider has reported recovery for all regions except GCP - US Central 1 (Iowa). We'll provide another update within 60 minutes.
Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features.
ETA: An ETA is not yet available. We'll provide one as soon as possible. In the meantime, we recommend that affected customers using replication across alternate cloud providers or currently unaffected regions initiate their failover procedures.
Incident start time: 17:55 UTC June 12, 2025
Posted Jun 12, 2025 - 12:53 PDT
Identified
Current status: We've identified an issue with a third-party service provider, and we're coordinating with the provider to develop and implement a fix to restore service. We'll provide another update within 60 minutes.
Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features.
ETA: An ETA is not yet available. We'll provide one as soon as possible. In the meantime, we recommend that affected customers using replication across alternate cloud providers initiate their failover procedures.
Posted Jun 12, 2025 - 11:53 PDT
Investigating
Current status: We're investigating an issue with Snowflake Data Cloud. We'll provide an update within 60 minutes.
Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features using Snowsight.
Posted Jun 12, 2025 - 11:28 PDT
This incident affected: GCP - Europe West 2 (London) (Snowflake Data Warehouse (Database), Snowpipe (Data Ingestion), Replication, Snowsight), GCP - US East 4 (N. Virginia) (Snowflake Data Warehouse (Database), Snowpipe (Data Ingestion), Replication, Snowsight), GCP - Europe West 3 (Frankfurt) (Snowflake Data Warehouse (Database), Snowpipe (Data Ingestion), Replication, Snowsight), GCP - US Central 1 (Iowa) (Snowflake Data Warehouse (Database), Snowpipe (Data Ingestion), Replication, Snowsight), and GCP - Europe West 4 (Eemshaven) (Snowflake Data Warehouse (Database), Snowpipe (Data Ingestion), Replication, Snowsight).