Azure - Central India (Pune): INC0084575
Incident Report for Snowflake
Postmortem

Snowflake Engineering has completed the postmortem of this service incident. A detailed Root Cause Analysis (RCA) is available on the Snowflake Community site:
https://community.snowflake.com/s/article/INC0084575

Posted May 24, 2023 - 08:41 PDT

Resolved
Current status: We've implemented the fix for this issue and monitored the environment to confirm that service was restored. If you experience additional issues or have questions, please open a support case via Snowflake Community.
Customer experience: Customers hosted in the specified regions may have been unable to execute queries.
Incident start time: 00:00 UTC May 17, 2023
Incident end time: 04:34 UTC May 17, 2023
Preliminary root cause: A managed hardware security module (HSM) key expired, which caused communication issues between the Services layer and the HSM for a portion of the customers in the region.
Posted May 16, 2023 - 22:30 PDT
This incident affected: Azure - Central India (Pune) (Snowflake Data Warehouse (Database)).