Azure - East US 2 (Virginia): INC0140946

Incident Report for Snowflake

Resolved

Current status: During our investigation, our internal metrics indicated the service has self-recovered. We're monitoring to ensure the issue is resolved while we investigate its underlying cause.

Customer experience: Customers hosted in the specified regions may have been unable to access or use multiple core Snowflake services and features. Affected users may have been unable to sign in, execute queries, or manage data.

Incident start time: 20:47 UTC August 14, 2025
Incident end time: 20:57 UTC August 14, 2025

Preliminary root cause: We identified an issue that affected components that support the metadata management database within our cloud services layer, impacting customer connectivity and query operations.

A root cause analysis (RCA) document will be published within seven business days.
Posted Aug 14, 2025 - 16:01 PDT

Monitoring

Current status: During our investigation, our internal metrics indicated the service has self-recovered. We're monitoring to ensure the issue is resolved while we investigate its underlying cause.

Customer experience: Customers hosted in the specified regions may have been unable to access or use multiple core Snowflake services and features. Affected users may have been unable to sign in, execute queries, or manage data.

Incident start time: 20:47 UTC August 14, 2025
Incident end time: 20:57 UTC August 14, 2025

Preliminary root cause: We identified an issue that affected components that support the metadata management database within our cloud services layer, impacting customer connectivity and query operations.
Posted Aug 14, 2025 - 15:17 PDT

Investigating

Current status: We're investigating an issue with Snowflake Data Cloud. We'll provide an update within 60 minutes.

Customer experience: Customers hosted in the specified regions may be unable to access or use multiple core Snowflake services and features. Affected users may be unable to sign in, execute queries, or manage data.
Posted Aug 14, 2025 - 14:13 PDT
This incident affected: Azure - East US 2 (Virginia) (Databases, Tables, and Views, Applications).