AZURE - Switzerland North - Snowflake Data Warehouse (Database): MI-20220309
Incident Report for Snowflake
Postmortem

Dear Customer,

Snowflake Engineering has completed the postmortem of this major incident. A detailed Root Cause Analysis is made available on the Snowflake Community site.

https://community.snowflake.com/s/article/MI-202200308

We apologize for the major incident and the impact on your applications.

If you have any questions or difficulty accessing the Snowflake community site, please send feedback by submitting a support case or calling Snowflake Technical Support.

Thank you,

Snowflake Support

Posted Mar 16, 2022 - 15:35 PDT

Resolved
Current status: We've implemented the fix for this issue and monitored the environment to confirm that service was restored. If you experience additional issues or have questions, please open a support case via Snowflake Community.

Customer experience: Customers hosted in the specified region may have been unable to create new Snowflake Accounts under their organizational accounts. A fix was applied to Trial to all Accounts in the Region to restore service.

Incident start time: 23:28 PT March 08, 2022

Incident end time: 14:52 PT March 09, 2022

A root cause analysis (RCA) document will be published within seven business days.
Posted Mar 09, 2022 - 15:28 PST
Monitoring
Current status: We've implemented the fix for this issue, and we'll continue to monitor the environment until we're confident all services are functioning properly.

Customer experience: Customers hosted in the specified region may have been unable to create new Snowflake Accounts under their organizational accounts. A fix was applied to Trial to all Accounts in the Region to restore service.

Incident start time: 23:28 PT March 08, 2022

Incident end time: 14:52 PT March 09, 2022
Posted Mar 09, 2022 - 15:10 PST
Update
Current status: We've identified the source of the issue, and we're developing and implementing a fix to restore service. We'll provide another update within 2 hours.

Customer experience: Customers hosted in the specified region may be unable to create new Snowflake Accounts under their organizational accounts. Trial accounts are no longer affected. The same fix applied to Trial Accounts is being applied to all Accounts in the Region and is currently 70% complete.

Incident start time: 23:28 PT March 08, 2022
Posted Mar 09, 2022 - 12:37 PST
Update
Current status: We've identified the source of the issue, and we're developing and implementing a fix to restore service. We'll provide another update within 60 minutes.

Customer experience: Customers hosted in the specified region may be unable to create new Snowflake Accounts under their organizational accounts. Trial accounts are no longer affected. The same fix applied to Trial Accounts is being applied to all Accounts in the Region and is currently 58% complete.

Incident start time: 23:28 PT March 08, 2022
Posted Mar 09, 2022 - 11:49 PST
Update
Current status: We've identified the source of the issue, and we're developing and implementing a fix to restore service. We'll provide another update within 60 minutes.

Customer experience: Customers hosted in the specified region may be unable to create new Snowflake Accounts under their organizational accounts. Trial accounts are no longer affected. The same fix applied to Trial Accounts is being applied to all Accounts in the Region and is currently 41% complete.

Incident start time: 23:28 PT March 08, 2022
Posted Mar 09, 2022 - 10:52 PST
Update
Current status: We've identified the source of the issue, and we're developing and implementing a fix to restore service. We'll provide another update within 60 minutes.

Customer experience: Customers hosted in the specified region may be unable to create new Snowflake Accounts under their organizational accounts. Trial accounts are no longer affected. The same fix applied to Trial Accounts is being applied to all Accounts in the Region and is currently 23% complete.

Incident start time: 23:28 PT March 08, 2022
Posted Mar 09, 2022 - 09:49 PST
Identified
Current status: We've identified the source of the issue, and we're developing and implementing a fix to restore service. We'll provide another update within 60 minutes.

Customer experience: Customers hosted in the specified region may be unable to create new Snowflake Accounts under their organizational accounts. Trial accounts are no longer affected. The same fix applied to Trial Accounts is being applied to all Accounts in the Region and is currently 15% complete.

Incident start time: 23:28 PT March 08, 2022
Posted Mar 09, 2022 - 08:49 PST
Investigating
Current status: We're investigating an issue with Snowflake Data Warehouse (Database). We'll provide an update within 60 minutes.

Customer experience: Customers hosted in the specified region may be unable to create new Snowflake Accounts under their organizational accounts. Trial accounts are unaffected.

Incident start time: 23:28 PT March 08, 2022
Posted Mar 09, 2022 - 07:50 PST
This incident affected: AZURE - Switzerland North (Snowflake Data Warehouse (Database)).