AWS - US East (N. Virginia): INC0082688
Incident Report for Snowflake
Postmortem

Snowflake Engineering has completed the postmortem of this service incident. A detailed Root Cause Analysis (RCA) is available on the Snowflake Community site:
https://community.snowflake.com/s/article/INC0082688

Posted Apr 21, 2023 - 21:17 PDT

Resolved
Current status: We've implemented the fix for this issue and monitored the environment to confirm that service was restored. If you experience additional issues or have questions, please open a support case via Snowflake Community.

Customer experience: Customers hosted in the specified regions may have experienced delays while attempting to execute queries. Affected customers might have encountered query failures.

Incident start time: 19:50 UTC April 18, 2023

Incident end time: 22:50 UTC April 18, 2023

A root cause analysis (RCA) document will be published within seven business days.

Preliminary root cause: A system configuration change caused a small subset of customers to experience query delays and extended compilation times.
Posted Apr 18, 2023 - 16:41 PDT
Monitoring
Current status: We've identified the source of the issue as a system configuration that was enabled earlier today. We have disabled this configuration now and customers have reported recovery. We'll continue to monitor the environment until we're confident all services are functioning properly.

Customer experience: Customers hosted in the specified regions may have experienced delays while attempting to execute queries. Affected customers might have encountered query failures.

Incident start time: 19:50 UTC April 18, 2023

Incident end time: 22:50 UTC April 18, 2023

Preliminary root cause: A system configuration change caused a small subset of customers to experience query delays and extended compilation times.
Posted Apr 18, 2023 - 16:18 PDT
Investigating
Current status: We've confirmed that this issue impacts service, and we're continuing to investigate to determine the source of the issue. We'll provide another update within 60 minutes.

Customer experience: Customers hosted in the specified regions may experience delays while attempting to execute queries. Affected customers may encounter query failures.

Incident start time: 19:50 UTC April 18, 2023
Posted Apr 18, 2023 - 15:20 PDT
This incident affected: AWS - US East (N. Virginia) (Snowflake Data Warehouse (Database)).