Current status: We have implemented recovery actions and telemetry indicates that service health has currently returned to normal. However, we are continuing to coordinate with our cloud provider to address the underlying issue affecting backend infrastructure health that may result in periods of intermittent performance impact. We are actively monitoring health and network connectivity of the affected components and will provide another update within 60 minutes.
Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features using Snowsight. Customers may see "something went wrong" or "no healthy upstream" error messages. Some customers may be able to access Snowsight but are unable to perform operations within the UI. Recovery may be inconsistent as different parts of Snowsight are restored.
ETA: Service is currently healthy; however an ETA for confirming resolution of the underlying infrastructure issue is not yet available. We’ll provide one as soon as possible. For affected customers using replication that have initiated their failover procedures, we don’t currently recommend failback to the region until after we have finished validating recovery.
Incident start time: 14:15 UTC June 15, 2026
Posted Jun 15, 2026 - 17:43 UTC
Update
Current status: Following our initial recovery actions, authentication and basic navigation have been restored for most customers; however, other core Snowsight features are continuing to experience failures or degraded performance. We have identified a network connectivity issue affecting infrastructure components used by Snowsight's backend infrastructure, and we are attempting to recover the affected components. We'll provide another update within 60 minutes.
Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features using Snowsight. Customers may see "something went wrong" or "no healthy upstream" error messages. Some customers may be able to access Snowsight but are unable to perform operations within the UI. Recovery may be inconsistent as different parts of Snowsight are restored.
ETA: An ETA is not yet available. We'll provide one as soon as possible.
Workaround: While we're focused on remediation, we recommend that affected customers using replication initiate their failover procedures.
Incident start time: 14:15 UTC June 15, 2026
Posted Jun 15, 2026 - 16:19 UTC
Identified
Current status: We've identified an issue affecting Snowsight backend infrastructure, and we're attempting to restart affected components to restore service. We'll provide another update within 30 minutes.
Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features using Snowsight. Customers may see "something went wrong" or "no healthy upstream" error messages. Some customers may be able to access Snowsight but are unable to perform operations within the UI.
ETA: An ETA is not yet available. We'll provide one as soon as possible. In the meantime, we recommend that affected customers using replication initiate their failover procedures.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 14:15 UTC June 15, 2026
Posted Jun 15, 2026 - 15:13 UTC
Investigating
Current status: We're investigating an issue with Snowflake Data Cloud. We'll provide an update within 30 minutes.
Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features using Snowsight.
Posted Jun 15, 2026 - 14:30 UTC
This incident affects: Azure - East US 2 (Virginia) (Applications).