Resolved
Current status: We've implemented the fix for this issue and monitored the environment to confirm that the service was restored. Some customers may experience delays in ingestion as the backlog of requests is cleared. If you experience additional issues or have questions, please open a support case via Snowflake Community.
Customer experience: Customers hosted in the specified regions may have been unable to execute queries and may have experienced query performance degradation. Additionally, data clustering may have appeared to be in an unhealthy state. Users may have experienced delays or failures when using Snowpipe or Snowpipe Streaming to ingest files, and users may have seen a "SQL execution internal error" message or similar error messages.
Workaround: There were no available workarounds for this issue except for customers with replication failing over to non-impacted regions.
Incident start time: 02:55 UTC December 16, 2025
Incident end time: 15:59 UTC December 16, 2025
Preliminary root cause: Our initial investigation has identified that our most recent release introduced a backwards-incompatible database schema update. As a result, previous release packages incorrectly referenced the updated fields, resulting in version mismatch errors and causing operations to fail or take an extended amount of time to complete.
A root cause analysis (RCA) document will be published within five business days.
Posted Dec 16, 2025 - 17:25 UTC
Monitoring
Current status: We've completed the resolution steps for the Azure - East U.S. 2 (Virginia) region. We expect that the majority of the impact should be mitigated at this time; however, we are currently monitoring and assessing for any residual impact. We'll continue to monitor the environment until we're confident all services are functioning properly. Since resolution is being observed in affected regions, failing over is no longer recommended for customers with replication enabled in other regions, unless they continue to experience impact.
Customer experience: Customers hosted in the specified regions may have been unable to execute queries and may have experienced query performance degradation. Additionally, data clustering may have also appeared to be in an unhealthy state. Users may have experienced delays or failures when using Snowpipe or Snowpipe Streaming to ingest files, and users may have seen a "SQL execution internal error" message or similar error messages.
Workaround: There were no available workarounds for this issue outside of customers with replication failing over to non-impacted regions.
Incident start time: 02:55 UTC December 16, 2025
Incident end time: 15:59 UTC December 16, 2025
Preliminary root cause: Our initial investigation has identified that our most recent release introduced a backwards-incompatible database schema update. As a result, previous release packages errantly referenced the updated fields, resulting in version mismatch errors and causing operations to fail or take an extended amount of time to complete.
Posted Dec 16, 2025 - 16:28 UTC
Update
Current status: We are continuing to work through the resolution steps for the Azure - East U.S. 2 (Virginia) region. We will provide another update within 30 minutes.
Customer experience: Customers hosted in the specified regions may be unable to execute queries and may experience query performance degradation. Data clustering may appear to be in an unhealthy state. Additionally, users may experience delays or failures when using Snowpipe or Snowpipe Streaming to ingest files. Affected users may see a "SQL execution internal error" message or similar error messages.
ETA: Our current estimated time for service resolution remains 16:30 UTC.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 15:57 UTC
Update
Current status: We are continuing to work through the resolution steps for the Azure - East U.S. 2 (Virginia) region, which are taking longer than previously estimated. We will provide another update within 30 minutes.
Customer experience: Customers hosted in the specified regions may be unable to execute queries and may experience query performance degradation. Data clustering may appear to be in an unhealthy state. Additionally, users may experience delays or failures when using Snowpipe or Snowpipe Streaming to ingest files. Affected users may see a "SQL execution internal error" message or similar error messages.
ETA: Our current estimate for service resolution has been updated to 16:30 UTC.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 15:29 UTC
Update
Current status: We've successfully mitigated all affected regions except Azure - East US 2 (Virginia), where we are continuing to work through the resolution steps for the remainder of the region. We will provide another update within 30 minutes.
Customer experience: Customers hosted in the specified regions may be unable to execute queries and may experience query performance degradation. Data clustering may appear to be in an unhealthy state. Additionally, users may experience delays or failures when using Snowpipe or Snowpipe Streaming to ingest files. Affected users may see a "SQL execution internal error" message or similar error messages.
ETA: Our current estimate remains that service will be restored by 15:00 UTC.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 15:00 UTC
Update
Current status: We continue executing our mitigation efforts and continue to see improvements in the affected regions. We continue working through the resolution steps. We will provide another update within 30 minutes.
Customer experience: Customers hosted in the specified regions may be unable to execute queries and may experience query performance degradation. Data clustering may appear to be in an unhealthy state. Additionally, users may experience delays or failures when using Snowpipe or Snowpipe Streaming to ingest files. Affected users may see a "SQL execution internal error" message or similar error messages.
ETA: Our current estimate remains that service will be restored by 15:00 UTC.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 14:44 UTC
Update
Current status: We continue executing our mitigation efforts and continue to see significant improvements in the affected regions. We continue working through the resolution steps. We will provide another update within 30 minutes.
Customer experience: Customers hosted in the specified regions may be unable to execute queries and may experience query performance degradation. Data clustering may appear to be in an unhealthy state. Additionally, users may experience delays or failures when using Snowpipe or Snowpipe Streaming to ingest files. Affected users may see a "SQL execution internal error" message or similar error messages.
ETA: Our current estimate remains that service will be restored by 15:00 UTC.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 14:15 UTC
Update
Current status: We continue executing our mitigation efforts and see significant improvements in the affected regions. We continue working through the resolution steps. We will provide another update within 30 minutes.
Customer experience: Customers hosted in the specified regions may be unable to execute queries and may experience query performance degradation. Data clustering may appear to be in an unhealthy state. Additionally, users may experience delays or failures when using Snowpipe or Snowpipe Streaming to ingest files. Affected users may see a "SQL execution internal error" message or similar error messages.
ETA: Our current estimate remains that service will be restored by 15:00 UTC.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 13:48 UTC
Update
Current status: We continue executing our mitigation efforts. As progress continues, customers will experience gradual improvements as we work through the resolution steps. We will provide another update within 30 minutes.
Customer experience: Customers hosted in the specified regions may be unable to execute queries and may experience query performance degradation. Data clustering may appear to be in an unhealthy state. Additionally, users may experience delays or failures when using Snowpipe or Snowpipe Streaming to ingest files. Affected users may see a "SQL execution internal error" message or similar error messages.
ETA: Our current estimate remains that service will be restored by 15:00 UTC.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 13:20 UTC
Update
Current status: We continue executing our mitigation efforts. As mitigation continues to progress, customers might expect gradual improvements as we work through the resolution steps. We will provide another update within 30 minutes.
Customer experience: Customers hosted in the specified regions may be unable to execute queries and may experience query performance degradation. Data clustering may appear to be in an unhealthy state. Additionally, users may experience delays or failures when using Snowpipe or Snowpipe Streaming to ingest files. Affected users may see a "SQL execution internal error" message or similar error messages.
ETA: Our current estimate remains that service will be restored by 15:00 UTC.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 12:50 UTC
Update
Current status: We are executing our mitigation efforts. As mitigation progresses, customers might expect gradual improvements as we work through the resolution steps. We will provide another update within 30 minutes.
Customer experience: Customers hosted in the specified regions may be unable to execute queries and may experience query performance degradation. Data clustering may appear to be in an unhealthy state. Additionally, users may experience delays or failures when using Snowpipe or Snowpipe Streaming to ingest files. Affected users may see a "SQL execution internal error" message or similar error messages.
ETA: Our current estimate is that service will be restored by 15:00 UTC. In the meantime, we recommend that customers using replication affected by this issue initiate their failover procedures.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 12:21 UTC
Update
Current status: We've resolved the unexpected issues. We're continuing with our mitigation efforts. We will provide another update within 2 hours.
Customer experience: Customers hosted in the specified regions may be unable to execute queries and may experience query performance degradation. Data clustering may appear to be in an unhealthy state. Additionally, users may experience delays or failures when using Snowpipe or Snowpipe Streaming to ingest files. Affected users may see a "SQL execution internal error" message or similar error messages.
ETA: Our current estimate is that service will be restored by 14:00 UTC. In the meantime, we recommend that customers using replication affected by this issue initiate their failover procedures.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 10:31 UTC
Update
Current status: Validation of our solution has encountered an unexpected issue. We've resolved these issues, and we're continuing with our mitigation efforts. We will provide another update within 2 hours.
Customer experience: Customers hosted in the specified regions may be unable to execute queries and may experience query performance degradation. Data clustering may appear to be in an unhealthy state. Additionally, users may experience delays or failures when using Snowpipe or Snowpipe Streaming to ingest files. Affected users may see a "SQL execution internal error" message or similar error messages.
ETA: Our current estimate is that service will be restored within 4 hours. In the meantime, we recommend that affected customers using replication initiate their failover procedures.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 08:36 UTC
Update
Current status: We're continuing our validations and will provide another update within 2 hours, after which we anticipate the fix will begin deploying.
Customer experience: Customers hosted in the specified regions may be unable to execute queries and may experience query performance degradation. Data clustering may appear to be in an unhealthy state. Additionally, users may experience delays or failures when using Snowpipe or Snowpipe Streaming to ingest files. Affected users may see a "SQL execution internal error" message or similar error messages.
ETA: Our current estimate is that service will be restored within 4 hours. In the meantime, we recommend that affected customers using replication initiate their failover procedures.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 06:40 UTC
Update
Current status: We're performing the final rounds of validation to ensure the fix will effectively restore service. We'll provide another update within 30 minutes.
Customer experience: Customers hosted in the specified regions may be unable to execute queries and may experience query performance degradation. Data clustering may appear to be in an unhealthy state. Additionally, users may experience delays or failures when using Snowpipe or Snowpipe Streaming to ingest files. Affected users may see a "SQL execution internal error" message or similar error messages.
ETA: Our current estimate is that service will be restored within 4 hours. In the meantime, we recommend that affected customers using replication initiate their failover procedures.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 05:50 UTC
Update
Current status: We've developed the fix, and we're preparing it for deployment to the affected regions. We'll provide another update within 60 minutes.
Customer experience: Customers hosted in the specified regions may be unable to execute queries. Additionally, users may experience delays or failures when using Snowpipe or Snowpipe Streaming to ingest files. Affected users may see a "SQL execution internal error" message or similar error messages.
ETA: Our current estimate is that service will be restored within 5 hours. In the meantime, we recommend that affected customers using replication initiate their failover procedures.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 05:04 UTC
Identified
Current status: We've identified the source of the issue, and we're developing a fix to resolve the impact. We'll provide another update within 60 minutes.
Customer experience: Customers hosted in the specified regions may be unable to execute queries. Affected users may see a "SQL execution internal error" message or similar error messages.
ETA: An ETA is not yet available. We'll provide one as soon as possible. In the meantime, we recommend that affected customers using replication initiate their failover procedures.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 04:34 UTC
Investigating
Current status: We're investigating an issue with Snowflake Data Cloud. We'll provide an update within 60 minutes.
Customer experience: Customers hosted in the specified regions may be unable to execute queries. Affected users may see a "SQL execution internal error" message or similar error messages.
Incident start time: 02:55 UTC December 16, 2025
Posted Dec 16, 2025 - 03:48 UTC
This incident affected: Azure - East US 2 (Virginia) (Databases, Tables, and Views, Data Loading and Unloading), AWS - US West (Oregon) (Databases, Tables, and Views, Data Loading and Unloading), AWS - Europe (Ireland) (Databases, Tables, and Views, Data Loading and Unloading), AWS - Asia Pacific (Mumbai) (Databases, Tables, and Views, Data Loading and Unloading), Azure - Switzerland North (Zürich) (Databases, Tables, and Views, Data Loading and Unloading), GCP - Europe West 2 (London) (Databases, Tables, and Views, Data Loading and Unloading), Azure - Southeast Asia (Singapore) (Databases, Tables, and Views, Data Loading and Unloading), Azure - Mexico (Central) (Databases, Tables, and Views, Data Loading and Unloading), Azure - Sweden Central (Gävle) (Data Loading and Unloading), and Azure - Sweden Central (Gävle).