Azure - East US 2 (Virginia): INC0146178

Incident Report for Snowflake

Resolved

Current status: We've monitored our service health metrics after disabling the background maintenance process, and we've confirmed that this has resolved the issue. If you experience additional issues or have questions, please open a support case via Snowflake Community.

Customer experience: Customers hosted in the specified regions may have been unable to access or use Snowflake services and features using Snowsight.

Incident start time: 15:27 UTC November 05, 2025
Incident end time: 18:36 UTC November 05, 2025

Preliminary root cause: A background maintenance process was contributing to periodic contention and degraded performance, which resulted in elevated load on a backend database. This caused intermittent errors and timeouts in Snowsight.

A root cause analysis (RCA) document will be published within five business days.
Posted Nov 05, 2025 - 20:10 UTC

Monitoring

Current status: We've disabled the background maintenance process that we've identified is contributing to the periodic contention and degraded performance of our service. We're closely monitoring our service health to ensure that this continues to provide relief and impact does not return. We'll provide another update within 60 minutes.

Customer experience: Customers hosted in the specified regions may have been unable to access or use Snowflake services and features using Snowsight.

Incident start time: 15:27 UTC November 05, 2025
Incident end time: 18:36 UTC November 05, 2025

Preliminary root cause: A background maintenance process was contributing to periodic contention and degraded performance, resulting in elevated load on a backend database. This caused intermittent errors and timeouts in Snowsight.
Posted Nov 05, 2025 - 19:49 UTC

Update

Current status: While our service health metrics indicate that impact may be occurring with less frequency, we're working to disable the background maintenance process that we've identified is contributing to the periodic contention and degraded performance of our service. We're closely monitoring our service health, and we'll provide another update within 60 minutes.

Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features using Snowsight.

ETA: We anticipate that our mitigation action to disable the background maintenance process contributing to impact should be complete in approximately two hours.

Incident start time: 15:27 UTC November 05, 2025
Posted Nov 05, 2025 - 18:14 UTC

Identified

Current status: We've observed elevated load on a backend database that is causing intermittent errors and timeouts in Snowsight. We've identified a background maintenance process that is contributing to periodic contention and degraded performance, and we're working on a mitigation to provide relief.

Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features using Snowsight.

ETA: An ETA is not yet available. We'll provide one as soon as possible. In the meantime, we recommend that affected customers using replication initiate their failover procedures.

Incident start time: 15:27 UTC November 05, 2025
Posted Nov 05, 2025 - 17:12 UTC

Investigating

Current status: We're investigating an issue with Snowflake Data Cloud. We'll provide an update within 60 minutes.

Customer experience: Customers hosted in the specified regions may be unable to access or use Snowflake services and features using Snowsight.
Posted Nov 05, 2025 - 15:58 UTC
This incident affected: Azure - East US 2 (Virginia) (Applications).