Current status: We've implemented the fix for this issue and monitored the environment to confirm that service was restored. If you experience additional issues or have questions, please open a support case via Snowflake Community or the Support page in Snowsight.
Customer experience: Customers hosted in the specified region may have observed stale or delayed data in account usage views and organization usage views.
Incident start time: 12:03 UTC May 04, 2026 Incident end time: 08:54 UTC May 05, 2026
Preliminary root cause: We identified an issue affecting a small number of internal metering files in this region. When Snowflake attempted to read these files as part of metering and account usage processing, the reads failed, blocking downstream processing.
A root cause analysis (RCA) document will be published within five business days.
Posted May 05, 2026 - 12:30 UTC
Monitoring
Current status: We've implemented the fix for this issue, and we'll continue to monitor the environment until we're confident all services are functioning properly.
Customer experience: Customers hosted in the specified region may have observed stale or delayed data in account usage views and organization usage views.
Incident start time: 12:03 UTC May 04, 2026 Incident end time: 08:54 UTC May 05, 2026
Preliminary root cause: We identified an issue affecting a small number of internal metering files in this region. When Snowflake attempted to read these files as part of metering and account usage processing, the reads failed, blocking downstream processing.
Posted May 05, 2026 - 11:30 UTC
Identified
Current status: We've identified an issue affecting a subset of internal metering files, causing a delay in account usage updates. We have now completed changes to exclude those files, allowing processes to resume. Data freshness in this region is now improving as the processing backfill catches up. We are validating the remaining backlog and any required backfill before marking full recovery. We'll provide another update within two hours.
Customer experience: Customers hosted in the specified region may observe stale or delayed data in account usage views and organization usage views. Usage reporting may not reflect activity after 16:00 UTC on May 4, 2026.
ETA: Our current estimate is that service will be restored within 2 hours.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 12:03 UTC May 04, 2026
Posted May 05, 2026 - 09:27 UTC
Update
Current status: We've identified an issue affecting a subset of data files, which is resulting in a delay for account usage updates. We are preparing changes to safely exclude the affected files and allow processing to resume. Account Usage data in the affected region remains delayed while we finalize validation of the impacted files and complete recovery steps. We’ll provide another update within four hours.
Customer experience: Customers hosted in the specified region may observe stale or delayed data in account usage views and organization usage views. Usage reporting may not reflect activity after 16:00 UTC on May 4, 2026.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 12:03 UTC May 04, 2026
Posted May 05, 2026 - 07:09 UTC
Update
Current status: We've identified an issue affecting a subset of data files, which is resulting in a delay for account usage updates. We're working on identifying a mitigation to restore normal processing. We'll provide another update within two hours.
Customer experience: Customers hosted in the specified region may observe stale or delayed data in account usage views and organization usage views. Usage reporting may not reflect activity after 16:00 UTC on May 4, 2026.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 16:50 UTC May 04, 2026
Posted May 05, 2026 - 05:10 UTC
Investigating
Current status: We're investigating an issue with Snowflake Data Cloud. We'll provide an update within 60 minutes.
Customer experience: Customers hosted in the specified region may observe stale or delayed data in account usage views and organization usage views. Usage reporting may not reflect activity after 16:00 UTC on May 4, 2026.
Workaround: There are currently no available workarounds for this issue.
Incident start time: 16:50 UTC May 04, 2026
Posted May 05, 2026 - 04:12 UTC
This incident affected: Azure - West US 2 (Washington) (Organization and Account Management).